Función SI

La función SI pertenece a la categoría de funciones lógicas de Excel, es una de las más utilizadas ya que permite ejecutar operaciones automáticas dependiendo del resultado de una comparación (prueba lógica) entre variables. Es de gran ayuda para la toma de decisiones automáticas.

Su sintaxis es la siguiente:

=SI(Prueba_lógica,hacer_si_verdadero,hacer_si_falso)

La función SI recibe tres argumentos: PRUEBA LÓGICA, VALOR SI VERDADERO, VALOR SI FALSO.

Para establecer una prueba lógica debemos utilizar dos valores y cualquier operador lógico, por ejemplo: 10>15, A1<B2, 10<>A1, B10=”Hola”

También podemos realizar operaciones cuyo resultado sea comparado en la prueba lógica, por ejemplo: (10+15)<(100*2), (A1*1.16)=SUMA(A2:A6)

El segundo argumento se utiliza para indicarle a Excel que operación o valor deberá devolver en el caso de que la prueba lógica sea VERDADERA, por ejemplo: =(10<15,”regresa esta cadena de texto”,FALSO),

=(10<15,SUMA(A2:A9),FALSO)

En el mismo sentido, el tercer argumento se utiliza para indicarle a Excel que operación o valor deberá devolver en el caso de que la prueba lógica sea FALSA, por ejemplo:

=(10<15,VERDADERO,”No califica para descuentos”)

Prueba_lógica (obligatorio): Expresión lógica que será evaluada para conocer si el resultado es VERDADERO o FALSO.
Valor_si_verdadero (opcional): El valor que se devolverá en caso de que el resultado de la Prueba_lógica sea VERDADERO.
Valor_si_falso (opcional): El valor que se devolverá si el resultado de la evaluación es FALSO.

 

Problemas comunes

Problema Qué ha fallado
0 (cero) en la celda No había argumento para valor_si_verdadero ni para valor_si_falso. Para que se devuelva un valor correcto, agregue texto de argumento a los dos argumentos, o agregue VERDADERO o FALSO al argumento.
#¿NOMBRE? en la celda Normalmente, esto significa que la fórmula se ha escrito mal.

Fuente: support.office.com


Ejemplo función SI

Ejercicio funcion SI – Determinación de descuentos